返回首页
当前位置: 主页 > 网络编程 > Jsp实例教程 >

IE下判断IE版本的代码语句<!--[if gte IE 6]> Only IE 6和以上版

时间:2018-11-24 22:39来源:知行网www.zhixing123.cn 编辑:麦田守望者

1. <!--[if !IE]><!--> 除IE外都可识别 <!--<![endif]-->
2. <!--[if IE]> 所有的IE可识别 <![endif]-->
3. <!--[if IE 5.0]> 只有IE5.0可以识别 <![endif]-->
4. <!--[if IE 5]> 仅IE5.0与IE5.5可以识别 <![endif]-->
5. <!--[if gt IE 5.0]> IE5.0以及IE5.0以上版本都可以识别 <![endif]-->
6. <!--[if IE 6]> 仅IE6可识别 <![endif]-->
7. <!--[if lt IE 6]> IE6以及IE6以下版本可识别 <![endif]-->
8. <!--[if gte IE 6]> IE6以及IE6以上版本可识别 <![endif]-->
9. <!--[if IE 7]> 仅IE7可识别 <![endif]-->
10. <!--[if lt IE 7]> IE7以及IE7以下版本可识别 <![endif]-->
11. <!--[if gte IE 7]> IE7以及IE7以上版本可识别 <![endif]-->

解释语句如下:
gt = selects greater than(高于)

lt = selects less than(低于)

gte = selects greater than or equal to(>=)

lte = selects less than or equal to(<=)

! = selects everything except what directly follows the "!"(选择所有,除了!)

例子:
<!--[if IE]>
<h1>您正在使用IE浏览器</h1>
<!--[if IE 5]>
<h2>版本 5</h2>
<![endif]-->
<!--[if IE 5.0]>
<h2>版本 5.0</h2>
<![endif]-->
<!--[if IE 5.5]>
<h2>版本 5.5</h2>
<![endif]-->
<!--[if IE 6]>
<h2>版本 6</h2>
<![endif]-->
<!--[if IE 7]>
<h2>版本 7</h2>
<![endif]-->
<!--[if IE 8]>
<h2>版本 8</h2>
<![endif]-->
<![endif]-->

------分隔线----------------------------
标签(Tag):判断IE版本的代码语句
------分隔线----------------------------
推荐内容
猜你感兴趣